MoxiEngage CRM Maintenance - Sunday, March 16th, 2025, 23:00 PDT
Completed
Scheduled for 2025-03-17 at 6:00 AM – 8:08 AM
Affects
MoxiEngage
Under maintenance from 6:00 AM to 8:08 AM
Updates
Completed
2025-03-17 at 8:08 AM
Completed
2025-03-17 at 8:08 AM
Maintenance has completed successfully.
In progress
2025-03-17 at 6:00 AM
In progress
2025-03-17 at 6:00 AM
Maintenance is now in progress
Planned
2025-03-17 at 6:00 AM
Planned
2025-03-17 at 6:00 AM
We are planning for a scheduled maintenance during that time. Moxi Engage will be unavailable while database upgrades are performed. This work is expected to be completed within the standard 4-hour window, ending no later than 3AM PDT.