All systems operational

MoxiBalance isn't accessible at the moment

Resolved
Major outage
Started 25 days ago Lasted 6 minutes

Affected

MoxiBalance
Updates
  • Resolved
    Resolved

    MoxiBalance All services are now operational

  • Investigating
    Investigating

    MoxiBalance We've been made aware of a possible service disruption. We will update you when we know more.